Back to overview
Degraded

Service Degradation: Delayed Async Results Delivery

Oct 28 at 12:10pm UTC
Affected services
Phone DNC (Asynchronous)
Phone TCPA (Asynchronous)
Phone Verification (Asynchronous)
Property Lookup All-Attributes (Asynchronous)
Property Search (Asynchronous)
Property Skip-Trace (Asynchronous)

Resolved
Oct 28 at 04:44pm UTC

Affected services are back to normal.

We have identified the root cause of the issue and it is now resolved.

What Happened

We experienced a large volume of async requests that introduced an added latency for delivering the jobs results.

Resolution

We have immediately taken action to scale up the processing throughput and ensure that all requests receive their expected results as soon as possible.

What We're Doing to Prevent This

We are continuously improving our async processing throughput and scaling our resources to match the increased demand.

Created
Oct 28 at 12:10pm UTC

Async requests are taking significantly longer to process than normal. Our team has been notified and we are investigating.