Back to overview
Degraded

Service Degradation: Delayed Async Results Delivery

Jul 15 at 03:58pm UTC
Affected services
Phone DNC (Asynchronous)
Phone TCPA (Asynchronous)
Phone Verification (Asynchronous)
Property Lookup All-Attributes (Asynchronous)
Property Search (Asynchronous)

Resolved
Jul 15 at 04:38pm UTC

Affected services are back to normal.

We have identified the root cause of the issue and it is now resolved.

What Happened

We experienced a second service outage caused by a database driver and server version mismatch issue. This incident occurred shortly after our previous outage, and we understand the frustration this has caused our customers.

Root Cause

The outage was triggered by incompatible database driver and server versions that created conflicts during system operations, leading to service disruption.

Resolution

Our technical team identified the version mismatch and successfully synchronized the relevant system components to restore full service functionality.

What We're Doing to Prevent This

We're taking immediate action to address both the specific cause and broader deployment practices:

  • Enhanced Version Control: We're implementing stricter version compatibility checks and automated validation processes to prevent database version mismatches before they reach production.

  • Improved Deployment Procedures: We're strengthening our deployment protocols to include comprehensive additional pre-deployment testing and rollback procedures.

  • Additional Testing: We're expanding our testing framework to include more rigorous compatibility testing across all system components.

  • Accelerated Infrastructure Improvements: Given the proximity of these incidents, we're prioritizing the infrastructure upgrades and monitoring improvements mentioned in our previous update.

Created
Jul 15 at 03:58pm UTC

Async requests are taking significantly longer to process than normal. Our team has been notified and we are investigating.