Back to overview
Downtime

Outage: API and Dashboard Unavailable

Jul 13 at 01:29pm UTC
Affected services
Health
Address Autocomplete
Address Geocode
Address Reverse-Geocode
Address Verify
Phone DNC
Phone DNC (Asynchronous)
Phone TCPA
Phone TCPA (Asynchronous)
Phone Verification
Phone Verification (Asynchronous)
Property Lookup All-Attributes
Property Lookup All-Attributes (Asynchronous)
Property Search
Property Search (Asynchronous)
Property Skip-Trace

Resolved
Jul 14 at 01:00am UTC

All services are back up and running.

What Happened

We experienced a system outage that affected service availability. While our team quickly identified the technical issue, the incident occurred during weekend hours when technical resources were limited, resulting in an extended resolution time.

Resolution

Our technical team successfully resolved the issue and restored full service functionality.

What We're Doing to Prevent This

We've implemented several improvements to strengthen our response capabilities:

  • Enhanced On-Call Support: We've established a more efficient on-call rotation system to ensure technical resources are readily available around the clock, including weekends and holidays.

  • Improved Monitoring & Alerting: We're deploying advanced monitoring and alerting mechanisms that will provide faster detection and notification of any potential issues.

  • Infrastructure Upgrades: We're rolling out significant infrastructure improvements and upgrades designed to reduce the likelihood of similar incidents occurring in the future.

Updated
Jul 13 at 01:51pm UTC

We have identified the root cause of the issue. However, we are having some trouble allocating the needed technical resources to resolve it.

We are doing the best we can to resolve it asap.

Created
Jul 13 at 01:29pm UTC

All services are down. Our team has been notified and we are investigating.